Blog de dada

DevOps, bidouilleur et routard plein de logiciels libres

Firefox : tester la compatibilité de vos extensions avec e10s

Rédigé par dada / / 10 commentaires




Quand est arrivé e10s, la gestion du multiprocessus, on a tous voulu en profiter. Normal, on nous annonce que Firefox va devenir une bête de course, on ne va quand même pas passer à côté ! Si vous tournez avec le navigateur le plus efficace du moment, pensez à vérifier que vous en exploitez bien toute la puissance !

Comment ? Avec Add-on Compatibility Reporter ! Il s'installe tout simplement en tant que module et va vous fournir ce type d'information précieuse :



Eh oui, il va vous dire si une de vos extensions vous empêche de jouer avec les dernières avancées du butineur. J'avais peur du résultat de l'analyse de mes extensions mais seule celle gérant la suppression des cookies m'a posé problème. J'ai trouvé une alternative avec Cookie AutoDelete et le tour était joué.

Vous n'avez plus aucune raison de ne plus parcourir le web à la vitesse grand V. Et si vous êtes un utilisateur de Chromium, dommage.

10 commentaires

#1  - Gilles a dit :

Entre e10s et les webextensions de FF 57, ça permet de faire du tri dans ses extensions et surtout de remplacer les obsolètes non mises à jour par des plus récentes.
Je pleure "autocopy 2" mais j'ai trouvé un remplaçant, cité... dans les reviews de la page FF :)

Répondre
#2  - Gilles a dit :

Et je n'ai pas compris le rapport avec Chromium.
Sur mon ordi perso, FF me permet de parcourir le Web.
Chromium me le permet aussi mais à vitesse grand V...
#ordinosaure

Répondre
#3  - dada a dit :

Chromium, Google, toussa toussa. J'ai glissé un troll gratuit dans mon billet :)

Si tu veux, je peux te rediriger vers un ancien article sur l'avènement de Chrome : https://www.dadall.info/blog/index.php?article504/mozilla-depecee

Ça explique un peu ma dent contre Google Chrome.

Répondre
#4  - Fla a dit :

Tu as de base, dans la pages des modules complémentaires de Firefox, l'indication "Multiprocess is enabled" en haut à droite puis, pour chaque module "Multiprocess compatible" (ou pas, selon l'état). Pas besoin d'un module de + pour ca ;) Il a été mis en place au début, lors de l'activation goutte à goutte d'e10s, mais c'est fini ca ;)

Répondre
#5  - dada a dit :

Sur Firefox 54, je n'ai pas les infos dont tu parles. Par contre, avec l'extension, ça apparaît bien. T'as des détails ?

Répondre
#6  - Pafzedog a dit :

Bizarre, je suis sur Firefox nightly et sans cette extension je n'ai pas ces informations non plus :/

Répondre
#7  - iGor a dit :

« de base », à savoir quand le module mentionné est activé… :)

Répondre
#8  - 2passage a dit :

Hello.

https://bugzilla.mozilla.org/show_bug.cgi?id=1345661#c19

Ce commentaire résume bien pourquoi Mozilla/Firefox perds ses utilisateurs, même libristes convaincus !

Six mois plus tard, toujours pas de solution venant de Mozilla/Firefox. Et toute discussion sur le sujet est un monologue....

Et finalement, Chrome n'est pas si mal....

Merci Mozilla de nous pousser vers les logiciels privateurs.

La «vitesse» n'est pas tout...

Répondre
#9  - dada a dit :

J'ai bien envie de simplement répondre que je n'ai pas de soucis avec PulseAudio :)

Répondre
#10  - 2passage a dit :

Hello.
Je n'ai rien contre pulse audio, en général, tant qu'il n'est pas sur ma machine.
En effet, c'est certainement très utile à un certain public, mais très désagréable quand on utilise son ordinateur en m.a.o
Le vrai problème est que Mozilla en fasse une dépendance bloquante. Méprisant l'api de base du noyau, Alsa, avec des arguments douteux. Et faisant le changement de manière un peu..cavalière. Google n'aurait pas fait mieux dans le respect de ses utilisateurs...
Pour le reste, les derniers chiffres d'utilisation de Firefox face à ses concurrents sont sûrement excellents, Mozilla peut se permettre de tourner le dos à ses utilisateurs historiques. Wait&See.

Répondre

Fil RSS des commentaires de cet article

Écrire un commentaire

Quelle est la dernière lettre du mot oell ?